标签归档:centos

CentOS 6 PHP Mcrypt 支援問題

剛有學生詢問在 CentOS 6 底下 PHP 怎麼沒有 php-mcrypt 模組可以安裝,看了一下光碟內容確實沒這些套件,解決方式如下,可以透過EPEL (Extra Packages for Enterprise Linux) 套件庫來解決缺少的相關套件:

首先,安裝對應的Release檔案:rpm -ivh http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-5.noarch.rpm
接著,更新套件庫:yum update
更新後,可以透過 yum repolist 看到套件庫清單中已經有一個新的套件庫,名稱為 epel
之後再試試看 yum install php-mcrypt 便可以透過 epel 套件庫來安裝

转自:http://figaro.neo-info.net/?p=754&cpage=1#comment-300