群晖升级dsm后,vpn套件报不兼容,停止服务。

升级了dsm,本来的vpn套件是1.4.4-2855,没有更新的版本,但是升级后,就停止服务了。说:安装的套件与您的dsm不兼容
找了一圈没有更新的版本,但是说明有,于是拼了个url,

https://global.download.synology.com/download/Package/spk/VPNCenter/1.4.6-2892/VPNCenter-x86_64-1.4.6-2892.spk?model=DS220%2B&bays=2&dsm_version=7.0.1&build_number=42218

下载后手工安装 ok。

之后发现了这个网站。
https://www.synoforum.com/resources/latest-versions-of-dsm-srm-and-packages.165/

How to Test Port [TCP/UDP] Connectivity from a Linux Server with nc

yum install nc

# nc -z -v [hostname/IP address] [port number]

# nc -z -v 192.168.10.12 22
Connection to 192.118.20.95 22 port [tcp/ssh] succeeded!

# nc -z -v 192.168.10.12 22
nc: connect to 192.118.20.95 port 22 (tcp) failed: No route to host

# nc -z -v -u [hostname/IP address] [port number]

# nc -z -v -u 192.168.10.12 123
Connection to 192.118.20.95 123 port [udp/ntp] succeeded!

mikrotik routeros auto send pppoe ip email script

email的发送设置,可以从 Tools / Email 进行设置,测试看是否可以成功发送。
代码如下,代码记得前后要有大括号!!
{#上网接口名称
:local PPPInterface "ros_pppoe";
#设备名称
:local whoami "Hi,";
#发送Email的主题
:local Themes "ROS Email Assistant";
#发送内容
:local Contents "IP Address: ";
:local SendEmailTo "xxxxx@qq.com";
#获取接口IP地址
:local getip [ /ip address get [/ip address find interface=$PPPInterface ] address ];
:global IPAddress [:pick $getip 0 [:find $getip "/" ] ];
#获取system版本
:global ROSVersion ("RouterOS Version: v" . [/system package get [/system package find name=routeros] version] );
#发送Email设置
/tool e-mail send to=$SendEmailTo subject=$Themes body=("$whoami\n$Contents$IPAddress\n$ROSVersion");
#日志提醒
:log warning "系统数据已备份,邮件已发送至($SendEmailTo)";
:log warning ("外网IP =" ."$IPAddress");
}

Create Persistent Cronjobs on VMware ESXi for ghettoVCB Backups

Edit /etc/rc.local.d/local.sh, insert this before the exit 0 line:
/bin/kill $(cat /var/run/crond.pid)
/bin/echo “0 21 * * 5 /opt/ghettovcb/bin/ghettoVCB.sh -a -g /vmfs/volumes/<$DATASTORE>/ghettoVCB.conf > /vmfs/volumes/<$BACKUP_DATASTORE>/Backups/ghettoVCB-\$(date +%s).log” >> /var/spool/cron/crontabs/root
/usr/lib/vmware/busybox/bin/busybox crond
Run the script:
/bin/sh /etc/rc.local.d/local.sh
Make the changes persistent:
/bin/auto-backup.sh

安装指定版本的ne1000网卡驱动
esxcli software vib install -n ne1000:0.8.4-10vmw.700.1.0.15843807 -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml
esxcli software vib install -n ne1000:0.8.4-11vmw.703.0.20.19193900 -d https://hostupdate.vmware.com/software/VUM/PRODUCTION/main/vmw-depot-index.xml

群晖的ddns获取公网ip不正确的问题

群晖设置ddns和quickconnect,如果内网有旁路由,会有问题,先手工指定网关,完成upnp的设置,再改回来,利用本身的功能进行一下端口映射,之后就没问题了。

遇到了问题获取公网ip不对,是因为旁路由设置了国外ip走代理,群晖判断ip地址的服务器应该是在国外,所以获取的地址不是实际的nas地址。

旁路由的梯子改成gfw的规则就行,或者可以将群晖的服务器设置为白名单,直接链接?不过我不知道他们的域名。困扰了多天,可以解决了。。

windows 11 安卓子项目 增加代理

D:\prog\WSAToolbox>adb kill-server

D:\prog\WSAToolbox>adb devices
* daemon not running; starting now at tcp:5037
* daemon started successfully
List of devices attached

D:\prog\WSAToolbox>adb.exe connect 172.22.34.229:5555
connected to 172.22.34.229:5555

安卓系统的ip地址

D:\prog\WSAToolbox>d:

D:\prog\WSAToolbox>adb shell settings put global http_proxy 172.22.32.1:10809

Ethernet adapter vEthernet (WSL): 的地址

 

删除代理

adb shell settings delete global http_proxy

adb shell settings delete global global_http_proxy_host

adb shell settings delete global global_http_proxy_port